Important Update Effective February 1, 2024!
Due to recent changes in Jira and Confluence, we've made the tough decision to discontinue the OpenID Connect (OIDC)/OAuth app and no longer provide new versions for the newest Jira/Confluence releases as of January 31, 2024.
This is due to some necessary components no longer shipping with Jira/Confluence, which would require some extensive rewrites of the OIDC App.
Important Update! This app will be discontinued soon!
Due to recent changes in Jira, which no longer ships with some components required for our Read Receipts app to run, we've made the tough decision to discontinue the app, as of Februar 5, 2025.
Important Update! This app will be discontinued soon!
We've made the tough business decision to discontinue the app, as of January 11, 2025.
Clicking a NetDocuments hyperlink causes Microsoft Office to hang for 60 seconds
Problem:
For clients who use Active Directory Federated Services (ADFS) as their federated identity provider, when clicking on NetDocuments hyperlinks embedded in documents from within the following Microsoft Office products:
- Word
- Excel
- PowerPoint
the chosen Office product appears to hang for 60 seconds and (Not Responding) may become visible in the in the title bar before the page successfully loads in the browser.
The problem is not evident when clicking the same links in Outlook.
Cause:
Microsoft Office products (except Outlook) cannot share the token/cookie used by Internet Explorer.
This is a known limitation of the Office product line, it attempts to contact the site and meets a credentials prompt. Because the credentials prompt is a website it cannot be displayed by the Office product.
At this point, the program will appear unresponsive for the 60-second timeout.
Outlook uses a different way to interact with IE than the affected Microsoft Office products.
Resolution:
There is unfortunately not a complete resolution to this issue at the time of writing this article, the problem lies within the Microsoft Office product and Microsoft is aware of the issue.
To stop the unseen authentication prompt you must hit your ESCAPE key after clicking the NetDocuments hyperlink. This dismisses the prompt and skips the 60 second timeout period and just opens the link in the browser.
Alternatively, copy and paste the URL to the browser as necessary.
The problem is only noted with ADFS authenticated sites; other single sign-on (SSO) solutions are not similarly affected.