Problem

User Sync fails when trying to start a sync and states, that there is already a sync in progress.

Cause

Sometimes, and this should only happen in rare cases, User Sync is not able to update the status of a sync properly, so that the next sync can start.
We've seen this already during short database outages, network issues or other events at that time.

Resolution

Option 1

If feasible, disable and then enable the SAML SSO app from the app management section.
Many times this fixes the problem already.

Option 2

Depending on which version you are using, you can also update the records in the database to solve the problem.
If you are using User Sync as part of SAML, please refer to the first number, if using User Sync stand-alone, the second.

SAML SSO < 3.6.3 / User Sync < 1.5.2

Run this query first, it will return one or more Ids.

SELECT "ID" FROM "AO_F58FCA_SYNC_STATUS" where "STATUS" != 'DONE'
SQL

Use the id(s) in another update statement. The example below shows how to update records with id 1 and 7. If you have just one, only put this is between the brackets at the end.

UPDATE "AO_F58FCA_SYNC_STATUS" SET "STATUS" = 'DEAD' WHERE "ID" IN (1,7)
SQL

SAML SSO  3.6.3 +  / User Sync 1.5.2 +

Run this query first, it will return one or more Ids.

SELECT "ID" FROM "AO_F58FCA_SYNC_STATUS_DATA" where "STATUS" != 'DONE'
SQL

 Use the id(s) in another update statement. The example below shows how to update records with id 1 and 7. If you have just one, only put this is between the brackets at the end.

UPDATE "AO_F58FCA_SYNC_STATUS_DATA" SET "STATUS" = 'DEAD' WHERE "ID" IN (1,7)
SQL


After the update you should be able to run another sync again.